Go Back   Web Design & SEO Company > Knowledgebase

Knowledgebase Articles and information about running a website, cPanel and various hints and tips. Here you will find tutorials on php, MySql, .htaccess, cron, SEO, Search Engines, CHMOD, FTP, CSS, HTML and various other hints and tips on running and Administrating a website.

Reply
 
  #1  
Old 04-25-2009, 07:29 PM
Junior Member
 
Join Date: Apr 2009
Posts: 2
Default I am getting this error php rss

I got this script which fetches from rss to html
I am trying to fetch news from yahoo..
it doesn't matter where I fetch it from.. but it says I have some error on first line of the code

Quote:
Warning: set_time_limit() has been disabled for security reasons in /home/a3250669/public_html/SA/news/FreeRSStoHTML.php(35) : eval()'d code(1) : eval()'d code on line 1
this how first 19 line looks

Quote:
<?php

/*
Free php RSS to Content v1.27
By johnedwardsproperties.com
Free to use, please acknowledge me

Include the following where you want the feeds display, must be a PHP page.
Make sure to include the correct path to FreeRSStoHTML.php


<?php
include("FreeRSStoHTML.php");
?>

Place the URL of an RSS feed in the $URL_1 variable.
If you have additional RSS feeds place them into $URL_2 - $URL_5
The script will combines all the feeds together and shuffles the listings
*/
Reply With Quote
Top SEO Tool
Harvester and Mass Blog Commenter
Blog Comment Software

  #2  
Old 04-25-2009, 08:43 PM
Admin's Avatar
Administrator
 
Join Date: Jan 2007
Location: Taree
Posts: 607
Default

The warning you are getting set_time_limit() has been disabled for security reasons basically means the script is trying to reset the running time back to zero because it hasn't finished executing but the server is configured not to let it.

Your server is probably set to 30 seconds for the max_execution_time so processes don't keep running and crash the server. Give this a try, in your /public_html/ make a .htaccess file if you don't have one already and put this in it at the very top:

Quote:
php_value max_execution_time 90
This will tell the server scripts can run for 90 seconds now instead of 30, and this should be long enough for the RSS to finish without trying to use set_time_limit()

You "can" change the number higher than 90 but i don't recommend it on shared servers because you can cause big loads and the host won't be happy.
Reply With Quote
Top SEO Tool
Harvester and Mass Blog Commenter
Blog Comment Software

Reply

Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Error Pages Admin Knowledgebase 1 02-10-2009 04:44 AM
FTP Error Codes - Messages Admin Knowledgebase 2 12-07-2008 11:53 PM



Knowledgebase | SEO | Free Scripts | Free Wordpress Themes | Free Graphics

Micro Niche Finder Review - eval gzinflate base64 decode


Forum time zone is GMT. Currently it's 03:55 AM.


Forum SEO | Chrome Plugins

Web Design & SEO Forums